Docker Technical Articles

Package ‘docker-engine’ has no installation candidate

Package ‘docker-engine’ has no installation candidate

Description:

While installing Docker Engine in Ubuntu 16.04 getting the docker-engine has no installation candidate.

Error:

root@ubuntu:~# apt-get install docker-engine
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package docker-engine is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘docker-engine’ has no installation candidate

docker-engine : Depends: libsystemd-journal0 (>= 201) but it is not installable

Solution:

1. Need to update the repos in source list, vim /etc/apt/source.list

deb https://packages.docker.com/1.12/apt/repo/ ubuntu-xenial main
deb http://apt.dockerproject.org/repo/ ubuntu-trusty main
deb http://cz.archive.ubuntu.com/ubuntu trusty main

2. Re-run apt-get update and try to install apt-get install docker-engine

Tags: docker,docker container, Docker engine,docker-engine, Container , mytecharticle, technews, kubernetes, Docker swarm